FailureHandlingOptions Class


Failure Handling Options Class

Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FailureHandlingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailureHandlingOptions : IDisposable

The FailureHandlingOptions type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FailureHandlingOptions
Public method GetClearAfterRollback Obtains the flag indicating if all posted failures should be removed silently when transaction is being rolled back.
Public method GetDelayedMiniWarnings Obtains the flag indicating if showing of mini-warning dialog should be delayed until the end of next transaction.
Public method GetFailuresPreprocessor Gets the callback to be invoked in the beginning of failure processing.
Public method GetForcedModalHandling Obtains the flag indicating if the error handling dialog shown at the end of the failing transaction should be modal.
Public method GetTransactionFinalizer Gets the callback to be executed after transaction is completed.
Public method SetClearAfterRollback Sets a flag indicating that Revit should clear all posted failures silently when the failing transaction is being rolled back intentionally. If not set, the failures may still be displayed to the user during rollback.
Public method SetDelayedMiniWarnings Sets a flag indicating if Revit should delay the display of the mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) until the end of the next transaction.
Public method SetFailuresPreprocessor Sets the callback to be invoked in the beginning of failure processing.
Public method SetForcedModalHandling Sets a flag indicating whether Revit will show a modal (blocking) error dialog if the transaction failed to finish.
Public method SetTransactionFinalizer Sets the callback to be executed after the transaction is completed.
Top
See Also