SplitButtonData Class


Split Button Data Class

This class contains information necessary to construct a split button in the Ribbon.
Inheritance Hierarchy

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SplitButtonData : PulldownButtonData

The SplitButtonData type exposes the following members.

Constructors
Name Description
Public method SplitButtonData Constructs a new instance of SplitButtonData.
Top
Properties
Name Description
Public property Image The image of the button.
(Inherited from ButtonData )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ItemData )
Public property LargeImage The large image of the button.
(Inherited from ButtonData )
Public property LongDescription Long description of the command tooltip
(Inherited from RibbonItemData )
Public property Name The internal name of the item.
(Inherited from ItemData )
Public property Text The user-visible text of the button.
(Inherited from ButtonData )
Public property ToolTip The tooltip of item.
(Inherited from ItemData )
Public property ToolTipImage The image to show as a part of the button extended tooltip
(Inherited from RibbonItemData )
Top
Methods
Name Description
Public method Dispose
(Inherited from ItemData )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetContextualHelp Gets the contextual help bound with this control.
(Inherited from RibbonItemData )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetContextualHelp Sets the contextual help bound with this button data.
(Inherited from RibbonItemData )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also