GetRuleName Method (PerformanceAdviserRuleId)


Performance Adviser Get Rule Name(Performance Adviser Rule Id) Method

Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetRuleName(
	PerformanceAdviserRuleId id
)

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.

Return Value

String
The name of the rule.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also