CreateRevolvedGeometry Method (Frame, IList(CurveLoop), Double, Double, SolidOptions)


Geometry Creation Utilities Create Revolved Geometry(Frame, IList Curve Loop , Double, Double, Solid Options) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Solid CreateRevolvedGeometry(
	Frame coordinateFrame,
	IList<CurveLoop> profileLoops,
	double startAngle,
	double endAngle,
	SolidOptions solidOptions
)

Parameters

coordinateFrame Frame
profileLoops IList CurveLoop
startAngle Double
endAngle Double
solidOptions SolidOptions

Return Value

Solid
See Also