ResetCategoryToDefault Method


IFCCategory Template Reset Category To Default Method

Reset one category, sub-category, or special category in the current mapping table to the default values defined in Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExportIFCCategoryInfo ResetCategoryToDefault(
	ExportIFCCategoryKey categoryKey
)

Parameters

categoryKey ExportIFCCategoryKey
The selected category information.

Return Value

ExportIFCCategoryInfo
The default information.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also