FamilyCategoryId Property


Family Family Category Id Property

The id of the category or sub category in which the elements that this family could generate reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId FamilyCategoryId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The input category id cannot be assigned as the new category for this family.
ArgumentNullException When setting this property: A non-optional argument was null
InvalidOperationException When setting this property: The family is not an owner family for its own editable document.
See Also