BuildingEnvelopeDeterminationMethod Property


Energy Data Settings Building Envelope Determination Method Property

Indicates if an analysis should be perform to find the model elements that are part of the building envelope

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public gbXMLExportBuildingEnvelope BuildingEnvelopeDeterminationMethod { get; set; }

Property Value

gbXMLExportBuildingEnvelope
Exceptions
Exception Condition
ArgumentException When setting this property: The building envelope determination method does not fall within an appropriate range.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The analysis is performed for the detailed GreenBuildingXML export and in heating and cooling load calculations. This method uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. Analytical surface originated from the building elements in the envelope will be classified as exterior or shading surfaces.
See Also