ServerPath Class


Server Path Class

This class represents a path to a Revit Server location, rather than a location on disk or a network drive.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ServerPath : ModelPath

The ServerPath type exposes the following members.

Constructors
Name Description
Public method ServerPath Constructs a ServerPath
Top
Properties
Name Description
Public property CentralServerPath The path to the location of the central Revit server or cloud.
(Inherited from ModelPath )
Public property CloudPath Whether this path represents a path on an Autodesk server such as BIM360.
(Inherited from ModelPath )
Public property Empty Whether this path is empty
(Inherited from ModelPath )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ModelPath )
Public property Region The region of the BIM 360 Docs or Autodesk Docs account and project which contains this model.
(Inherited from ModelPath )
Public property ServerPath Whether this path is a server path (as opposed to a file path or cloud path)
(Inherited from ModelPath )
Top
Methods
Name Description
Public method Compare Compares this ModelPath with another
(Inherited from ModelPath )
Public method Dispose
(Inherited from ModelPath )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetModelGUID A GUID identifying the Revit cloud model.
(Inherited from ModelPath )
Public method GetProjectGUID A GUID identifying the BIM 360 Docs or Autodesk Docs project to which the model is associated.
(Inherited from ModelPath )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example, the following are valid server paths:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
The following would not be valid server paths:
  • //EXS/Old Files/.rvt
  • EXS/hospital
See Also