FamilyTypeSet Class


Family Type Set Class

A set that contains FamilyType objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyTypeSet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyTypeSet : APIObject, 
	IEnumerable

The FamilyTypeSet type exposes the following members.

Constructors
Name Description
Public method FamilyTypeSet Initializes a new instance of the FamilyTypeSet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Size Returns the number of objects that are in the set.
Top
Methods
Name Description
Public method Clear Removes every item from the set, rendering it empty.
Public method Contains
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Erase
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also