Push |
The PushButton object represents an button on a RibbonPanel.

System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PushButton
Autodesk.Revit.UI ToggleButton
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PushButton
Autodesk.Revit.UI ToggleButton
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)

The PushButton type exposes the following members.

Name | Description | |
---|---|---|
![]() | AssemblyName | The assembly path of the button. |
![]() | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. |
![]() | ClassName | The name of the class containing the implementation for the command. |

Name | Description | |
---|---|---|

Use of this class is not supported in Revit Macros.