Push |
The PushButton object represents an button on a RibbonPanel.

System Object
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PushButton
Autodesk.Revit.UI ToggleButton
Autodesk.Revit.UI RibbonItem
Autodesk.Revit.UI RibbonButton
Autodesk.Revit.UI PushButton
Autodesk.Revit.UI ToggleButton
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)

The PushButton type exposes the following members.

Name | Description | |
---|---|---|
![]() | AssemblyName | The assembly path of the button. |
![]() | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. |
![]() | ClassName | The name of the class containing the implementation for the command. |
![]() | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem ) |
![]() | Image | The image of the button. (Inherited from RibbonButton ) |
![]() | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton ) |
![]() | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem ) |
![]() | ItemType | Gets the item type. (Inherited from RibbonItem ) |
![]() | LargeImage | The large image shown on the button. (Inherited from RibbonButton ) |
![]() | LongDescription | Long description of the command tooltip (Inherited from RibbonItem ) |
![]() | Name | The name of the item. (Inherited from RibbonItem ) |
![]() | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem ) |
![]() | ToolTipImage | The image to show as a part of the button extended tooltip (Inherited from RibbonItem ) |
![]() | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem ) |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Inherited from RibbonItem ) |
![]() | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Use of this class is not supported in Revit Macros.