JoinGeometryUtils Class


Join Geometry Utils Class

Utilities for joining and unjoining elements, and for managing the order in which elements are joined.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB JoinGeometryUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class JoinGeometryUtils

The JoinGeometryUtils type exposes the following members.

Methods
Name Description
Public method Static member AreElementsJoined Determines whether two elements are joined.
Public method Static member GetJoinedElements Returns all elements joined to given element.
Public method Static member IsCuttingElementInJoin Determines whether the first of two joined elements is cutting the second element.
Public method Static member JoinGeometry Creates clean joins between two elements that share a common face.
Public method Static member SwitchJoinOrder Reverses the order in which two elements are joined.
Public method Static member UnjoinGeometry Removes a join between two elements.
Top
See Also