GetSpaceIds Method


Generic Zone Get Space Ids Method

Gets a list of ElementIds of the associated spaces for the zone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public ISet<ElementId> GetSpaceIds()

Return Value

ISet ElementId
The associated spaces for the space-based zone.
Exceptions
Exception Condition
InvalidOperationException This generic zone must be space-based.
See Also