Revision Create Method |
Creates a new Revision in the project.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- document Document
- The document of the new Revision.
Return Value
RevisionThe newly created Revision.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. |
ArgumentNullException | A non-optional argument was null |

The new Revision will be added at the end of the sequence of existing Revisions.