Solid |
Verifies if the cutting element can add a solid cut to the target element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool CanElementCutElement(
Element cuttingElement,
Element cutElement,
out CutFailureReason reason
)
Parameters
- cuttingElement Element
- The cutting element.
- cutElement Element
- The element to be cut.
- reason CutFailureReason
- The reason that the cutting element cannot add a solid cut to the cut element.
Return Value
BooleanTrue if the cutting element can add a solid cut to the target element, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |