IsChangeTriggered Method


Updater Data Is Change Triggered Method

Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsChangeTriggered(
	ElementId id,
	ChangeType type
)

Parameters

id ElementId
Id of element to check
type ChangeType
ChangeType to check

Return Value

Boolean
True if ChangeType happened to specified element
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also