BuiltInFailures.RegenFailures Class


Built In Failures Regen Failures Class

Failures about RegenFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures RegenFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class RegenFailures

The BuiltInFailures RegenFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotRegenFamily Can't regenerate Family [Family Name]. Edit Family to modify it.
Public property Static member CircularDependency There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyAssocProp There is a circular dependency between a Line created with Pick Support and the supporting member.
Public property Static member CircularDependencyAssocPropError There is a circular dependency between a Line created with Pick Support and the supporting member.
Public property Static member CircularDependencyConstraint Highlighted constraints cause a circular chain of references.
Public property Static member CircularDependencyConstraintError Highlighted constraints cause a circular chain of references.
Public property Static member CircularDependencyError There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyResolved There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
Public property Static member CircularDependencySketch Constraints in sketches of highlighted elements cause a circular chain of references.
Public property Static member CircularDependencySketchError There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyUncut There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyUncutError There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyWall There is a circular chain of references among the highlighted elements.
Public property Static member CircularDependencyWallError There is a circular chain of references among the highlighted elements.
Public property Static member ForceRegenSketch Regen Sketch
Public property Static member GeomStepFailed Can't rebuild geometry.
Public property Static member GeomStepFailedError Can't rebuild geometry.
Public property Static member RegenElements Regenerating elements.
Public property Static member RegeneratedElements Elements regenerated in pass [Regen Index]
Public property Static member RegenFailure Regeneration Failure.
Public property Static member UserCancelled Operation is cancelled by the user.
Public property Static member UserCancelledError Operation is cancelled by the user.
Top
See Also