DirectShapeReferenceOptions Class


Direct Shape Reference Options Class

This class is used to control the behavior of DirectShape and DirectShapeType reference objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DirectShapeReferenceOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectShapeReferenceOptions : IDisposable

The DirectShapeReferenceOptions type exposes the following members.

Constructors
Name Description
Public method DirectShapeReferenceOptions Constructs a new DirectShapeRefOptions instance with default settings.
Public method DirectShapeReferenceOptions(DirectShapeReferenceOptions) Constructs a new copy of the input DirectShapeRefOptions object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name associated with the reference object. The name does not need to be unique. The name must not be empty and must contain valid characters.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DirectShapeReferenceOptions
Public method GetExternalGeometryId Retrieves the ExternalGeometryId associated with the reference object.
Public method Static member IsValidExternalGeometryId Validates that the input ExternalGeometryId can be assigned to a direct shape reference.
Public method Static member IsValidReferenceName Validates that the input name can be assigned to a direct shape reference.
Public method SetExternalGeometryId Sets the ExternalGeometryId associated with the reference object. The ID must be non-empty.
Top
See Also