GetLevelInfos Method


Exporter IFC Get Level Infos Method

Note: This API is now obsolete.

Returns a collection containing the information about all levels in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This is deprecated in Revit 2026.  Use ExporterCacheManager.LevelInfoCache.LevelsById instead.")]
public IDictionary<ElementId, IFCLevelInfo> GetLevelInfos()

Return Value

IDictionary ElementId , IFCLevelInfo
The collection of level information.
Remarks
Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.
See Also