AddSegment Method


Fascia Add Segment Method

Add segments to the fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public override void AddSegment(
	Reference targetRef
)

Parameters

targetRef Reference
Segment's reference on which want to be added.
Exceptions
Exception Condition
ArgumentNullException This exception will be thrown in following cases: 1. Input targetRef is . 2. Input targetRef is not but contains nothing.
InvalidOperationException This exception will be thrown in following cases: 1. Input targetRef has already been added into the fascia. 2. Internal code fails to create the segment object. 3. Regeneration fails.
ArgumentOutOfRangeException This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Other fascia's horizontal edges
See Also