IsValidCategoryId Method


Direct Shape Is Valid Category Id Method

Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidCategoryId(
	ElementId categoryId,
	Document doc
)

Parameters

categoryId ElementId
Category id to be tested.
doc Document
Document to look up the category by id.

Return Value

Boolean
True if the category is allowed for a DirectShape or DirectShapeType, false if not.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also