Family |
Creates a new diameter dimension object using the default dimension type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- view View
- The view in which the dimension is to be visible.
- arcRef Reference
- Geometric reference of the arc to which the dimension is to be bound.
- origin XYZ
- The point where the witness line of the diameter dimension will lie.
Return Value
DimensionIf creation was successful the new diameter dimension is returned, otherwise an exception with failure information will be thrown.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when any input argument is . |
ArgumentException | Thrown when the argument arcRef is invalid. |
InvalidOperationException | Thrown when the creation failed. |

The currently user set default style is used for the created dimension.