PointOnPlane Class


Point On Plane Class

Define a ReferencePoint relative to a planar reference.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnPlane : PointElementReference

The PointOnPlane type exposes the following members.

Properties
Name Description
Public property Offset Signed offset from the plane.
Public property Position The coordinates of the point (or its projection) on the plane.
Public property XVec The X-coordinate vector of the point, in the plane's coordinate system.
Top
Methods
Name Description
Public method GetPlaneReference The geometric plane reference.
Public method Static member IsValidPlaneReference Check whether a geometry reference corresponds to a referenceable plane.
Public method Static member NewPointOnPlane Construct a PointOnPlane given a reference and a location in space.
Public method SetPlaneReference Change the geometric plane reference.
Top
Remarks
A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.
See Also