IsCounterclockwise Method


Curve Loop Is Counterclockwise Method

Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsCounterclockwise(
	XYZ normal
)

Parameters

normal XYZ
The normal vector to the plane used for this determination.

Return Value

Boolean
True if the curve loop is oriented counter-clockwise with respect to the specified 3D direction, false if the loop is oriented clockwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The curve loop is open or consists of a single unbound curve; counterclockwise determination has no meaning.
Remarks
CCW means that the projection of the CurveLoop onto a plane having "normal" as its oriented normal is CCW. This method should only be called if the loop is closed and has a non-singular projection onto the plane (i.e., the projection should have no self-intersections and should not be degenerate or even nearly degenerate). The return value in other cases is indeterminate.
See Also