CanLayerWidthBeNonZero Method


Compound Structure Can Layer Width Be Non Zero Method

Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public bool CanLayerWidthBeNonZero(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

Boolean
Remarks
This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx, and all regions to the right are assigned to layers with index > layerIdx.
See Also