BRep |
Creates an empty face in the geometry being built. Other BRepBuilder methods are used to add loops to the face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public BRepBuilderGeometryId AddFace(
BRepBuilderSurfaceGeometry surfaceGeom,
bool bFaceIsReversed
)
Parameters
- surfaceGeom BRepBuilderSurfaceGeometry
- The face's support surface.
- bFaceIsReversed Boolean
- True if the face's orientation is opposite to that of the surface, false if the orientations agree. The faces of each shell must be consistently oriented. For a solid (BRepType == Solid), the oriented face normals must point out of the solid; for a void (BRepType == Void), the face normals must point into the void. See the description of the bCoEdgeIsReversed input for AddCoEdge() for a discussion of the loop and co-edge orientation conventions to use with the BRepBuilder.
Return Value
BRepBuilderGeometryIdAn id that can be used to identify the face while the BRepBuilder is actively building geometry (e.g., to add a loop to a face).

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. |