CutWithHalfSpace Method


Boolean Operations Utils Cut With Half Space Method

Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Solid CutWithHalfSpace(
	Solid solid,
	Plane plane
)

Parameters

solid Solid
The input Solid to be cut.
plane Plane
The cut plane. The space on the positive side of the normal of the plane will be intersected with the input Solid.

Return Value

Solid
The newly created Solid.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also