Workset |
Set the default visibility of a workset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- worksetId WorksetId
- Id of the workset.
- visible Boolean
- Whether the workset should be visible by default or not.

Exception | Condition |
---|---|
ArgumentException | There is no workset with this Id in the document. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents. |