Autodesk.Revit.DB.Plumbing Namespace


Autodesk. Revit. DB. Plumbing Namespace

Classes
Class Description
Public class FlexPipe A flex pipe in the Autodesk Revit MEP product.
Public class FlexPipeType A flex pipe type in the Autodesk Revit MEP product.
Public class FluidTemperature Represents the dynamic viscosity and density properties as defined at a certain temperature.
Public class FluidTemperatureSetIterator An iterator to a set of FluidTemperature from FluidType.
Public class FluidType Has been extended to provide read and write access to a collection of FluidTemperature objects which represent the fluid's properties at various temperatures.
Public class Pipe A pipe in the Autodesk Revit MEP product.
Public class PipeFittingAndAccessoryConnectorData The input data used by external servers for calculation of the pipe fitting and pipe accessory coefficient.
Public class PipeFittingAndAccessoryData The input data used by external servers for calculation of the pipe fitting and pipe accessory coefficient.
Public class PipeFittingAndAccessoryPressureDropData The input and output data used by external servers for calculation of the pipe fitting and pipe accessory pressure drop.
Public class PipeFittingAndAccessoryPressureDropItem A flow path of the pipe/pipe fitting and accessory. It is defined by the begin connector and end connector
Public class PipeInsulation Represents insulation applied to the outside of a given pipe, fitting or content.
Public class PipeInsulationType This class represents a pipe insulation type in Autodesk Revit.
Public class PipePlumbingFixtureFlowData The input and output data used by external servers for calculation of the pipe plumbing fixture flow.
Public class PipePressureDropData The input and output data used by external servers for calculation of the pipe pressure drop.
Public class PipeScheduleType Represents a pipe schedule type in the Autodesk Revit MEP product.
Public class PipeSegment The PipeSegment class represents an instance of pipe segment which has the design data for routing preference.
Public class PipeSettings The pipe setting class.
Public class PipeType A pipe type element.
Public class PipingSystem A piping system element.
Public class PipingSystemType Base class for piping system types
Public class PlumbingUtils General utility methods in the Autodesk Revit MEP product.
Interfaces
Interface Description
Public interface IPipeFittingAndAccessoryPressureDropServer Interface class for external servers implementing pipe fitting and pipe accessory coefficient calculation.
Public interface IPipePlumbingFixtureFlowServer Interface class for external servers implementing Pipe plumbing fixture flow calculation.
Public interface IPipePressureDropServer Interface for external servers implementing pipe pressure drop calculation.
Enumerations
Enumeration Description
Public enumeration FlowConversionMode Enumerated type listing possible flow conversion modes for piping calculations.
Public enumeration PipeFlowConfigurationType An enumerated type listing all connector flow configuration
Public enumeration PipeFlowState An enumerated type listing all the pipe flow states for a pipe
Public enumeration PipeLossMethodType An enumerated type listing all pipe loss method types for a connector
Public enumeration PipeSystemType An enumerated type listing all the possible pipe system types for a connector object.