NewRoomBoundaryLines Method


Document New Room Boundary Lines Method

Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ModelCurveArray NewRoomBoundaryLines(
	SketchPlane sketchPlane,
	CurveArray curves,
	View view
)

Parameters

sketchPlane SketchPlane
The sketch plan
curves CurveArray
The geometry curves on which the boundary lines are
view View
The View for the new Room

Return Value

ModelCurveArray
Exceptions
Exception Condition
ArgumentException Thrown if the sketch plane does not exist in the given document.
ArgumentException Thrown if the view does not exist in the given document.
See Also