Revolved |
A surface of revolution defined by a profile curve and a local coordinate system. The surface is obtained by rotating the curve around Z axis of the local coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RevolvedSurface type exposes the following members.

Name | Description | |
---|---|---|
![]() | Axis | Axis of the revolved surface. This is the Z axis of the local coordinate system associated with this revolved surface. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from Surface ) |
![]() | OrientationMatchesParametricOrientation | Indicates whether this Surface's orientation is the same as or opposite to its parametric orientation. (Inherited from Surface ) |
![]() | Origin | Center of the circle that defines the base of the revolved surface. This is the origin of the local coordinate system associated with this revolved surface. |
![]() | XDir | X axis of the local coordinate system associated with this revolved surface. |
![]() | YDir | X axis of the local coordinate system associated with this revolved surface. |

Name | Description | |
---|---|---|
![]() ![]() | Create(Frame, Curve) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame and a profile curve. |
![]() ![]() | Create(XYZ, XYZ, Curve) | Creates a Surface object coincident with the surface of revolution defined by an axis and a profile curve. |
![]() ![]() | Create(Frame, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by a coordinate frame, a profile curve, and start and end angles of revolution. |
![]() ![]() | Create(XYZ, XYZ, Curve, Double, Double) | Creates a Surface object coincident with the surface of revolution defined by an axis, a profile curve, and start and end angles of revolution. |
![]() | Dispose | (Inherited from Surface ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundingBoxUV | Gets the UV bounding box of the surface. (Inherited from Surface ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetProfileCurve | Returns a copy of the profile curve expressed in the surface's coordinate system. |
![]() | GetProfileCurveInWorldCoordinates | Returns a copy of the profile curve expressed in the world coordinate system. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsValidProfileCurve(Frame, Curve) | Checks if the input profile curve is valid to create a surface of revolution in the given frame of reference. |
![]() ![]() | IsValidProfileCurve(XYZ, XYZ, Curve) | Checks if the input profile curve is valid to create a surface of revolution around the given axis. |
![]() | Project | Project a 3D point orthogonally onto a surface (to find the nearest point). Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ProjectWithGuessPoint | Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails. (Inherited from Surface ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The parametric equation of a surface of revolution is S(u, v) = center + C1(v)*cos(u)*xVec + C1(v)*sin(u)*yVec + C2(v)*zVec, where the profile curve in the SurfRev's xz plane has the parametric equation (C1(t), C2(t)). Note that the direction of X axis may agree or disagree with the chosen orientation of the surface.