GetCategoryMappingTable Method


IFCCategory Template Get Category Mapping Table Method

Gets the table that contains a mapping from Revit categories to IFC entities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IDictionary<ExportIFCCategoryKey, ExportIFCCategoryInfo> GetCategoryMappingTable(
	Document document
)

Parameters

document Document
The document.

Return Value

IDictionary ExportIFCCategoryKey , ExportIFCCategoryInfo
The mapping table.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also