ZoomAndCenterRectangle Method


UIView Zoom And Center Rectangle Method

Zoom and center the view to a specified rectangle.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void ZoomAndCenterRectangle(
	XYZ viewCorner1,
	XYZ viewCorner2
)

Parameters

viewCorner1 XYZ
A corner of the desired view rectangle in model coordinates.
viewCorner2 XYZ
The opposite corner of the desired view rectangle in model coordinates.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also