IPhotoRenderContext Interface


IPhoto Render Context Interface

An interface that is used in custom export to render 3D views of a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IPhotoRenderContext : IExportContext

The IPhotoRenderContext type exposes the following members.

Methods
Name Description
Public method Finish This method is called at the very end of the export process, after all entities were processed (or after the process was cancelled).
(Inherited from IExportContext )
Public method IsCanceled This method is queried at the beginning of every element.
(Inherited from IExportContext )
Public method Code example OnElementBegin This method marks the beginning of an element to be exported.
(Inherited from IExportContext )
Public method OnElementEnd This method marks the end of an element being exported.
(Inherited from IExportContext )
Public method Code example OnFaceBegin This method marks the beginning of a Face to be exported.
(Inherited from IExportContext )
Public method OnFaceEnd This method marks the end of the current face being exported.
(Inherited from IExportContext )
Public method Code example OnInstanceBegin This method marks the start of processing of an instance node (e.g. a family instance).
(Inherited from IExportContext )
Public method OnInstanceEnd This method marks the end of processing of an Instance Node (e.g. a family instance).
(Inherited from IExportContext )
Public method Code example OnLight This method marks the beginning of export of a light which is enabled for rendering.
(Inherited from IExportContext )
Public method Code example OnLinkBegin This method marks the beginning of a link instance to be exported.
(Inherited from IExportContext )
Public method OnLinkEnd This method marks the end of a link instance being exported.
(Inherited from IExportContext )
Public method Code example OnMaterial This method marks a change of the material.
(Inherited from IExportContext )
Public method Code example OnPolymesh This method is called when a tessellated polymesh of a 3d face is being output.
(Inherited from IExportContext )
Public method OnRPC This method marks the beginning of export of an RPC object.
(Inherited from IExportContext )
Public method Code example OnViewBegin This method marks the beginning of a 3D view to be exported.
(Inherited from IExportContext )
Public method OnViewEnd This method marks the end of a 3D view being exported.
(Inherited from IExportContext )
Public method Code example Start This method is called at the very start of the export process, still before the first entity of the model was send out.
(Inherited from IExportContext )
Top
Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The interface methods are then called at times of rendering entities that are currently visible in the view being rendered.

With this type of export context used to perform a custom export, Revit will traverse the model and output the model's geometry as if processing the Render command invoked via the UI. It means that only such elements that have actual geometry and are suitable to appear in a rendered view will be processed and output.

See Also