PolylineNode Class


Polyline Node Class

An output node that represents a 3D polyline.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB PolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PolylineNode : ModelCurveNode

The PolylineNode type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode )
Public property LineProperties Access to the line (pen) properties of the curve being drawn
(Inherited from ModelCurveNode )
Public property NodeName A readable name of the output node.
(Inherited from RenderNode )
Top
Methods
Name Description
Public method Dispose
(Inherited from RenderNode )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetPolyline Returns the polyline object corresponding to the node.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See also: [!:Autodesk::Revit::DB::IModelExportContext::OnPolyline] .
See Also