PolylineNode Class


Polyline Node Class

An output node that represents a 3D polyline.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderNode
Autodesk.Revit.DB ModelCurveNode
Autodesk.Revit.DB PolylineNode

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PolylineNode : ModelCurveNode

The PolylineNode type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetPolyline Returns the polyline object corresponding to the node.
Top
Remarks
See also: [!:Autodesk::Revit::DB::IModelExportContext::OnPolyline] .
See Also