BuiltInFailures.AssemblyFailures Class


Built In Failures Assembly Failures Class

Failures related to Assemblies.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures AssemblyFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AssemblyFailures

The BuiltInFailures AssemblyFailures type exposes the following members.

Properties
Name Description
Public property Static member AddedElementsNotSamePhaseAsAssembly Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
Public property Static member AssemblyDeleteTypeWarn Edits to these assemblies changed the naming category and name of these assemblies.
Public property Static member AssemblyDidNotMatchRequestedTypeWarn Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
Public property Static member AssemblyDisassembleInstanceWarn Edits to these assemblies changed the naming category and name of these assemblies.
Public property Static member AssemblyInheritTypeWarn Edits to these assemblies do not match existing types, new type will be created.
Public property Static member AssemblyInvalidMember Some elements became ineligible to be included in an assembly and were removed.
Public property Static member AssemblyNewTypeWarn Edits to these assemblies match existing type and will inherit that name.
Public property Static member AssemblyRenameTypeWarn Edits to these assemblies changed the naming category and name of these assemblies.
Public property Static member CouldNotAcquireAssemblyViews The assembly instance could not acquire the assembly views.
Public property Static member CouldNotChangeTypeOfAssembly Assembly cannot be changed to selected type.
Public property Static member DeleteAssemblyInstWithViewsWarn Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
Public property Static member DeleteShopDrawingsWarn The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
Public property Static member ElementsNotAllowedAreNotAddedToAssembly Elements not allowed in Assembly were not added to it, but only in the document
Public property Static member IneligibleElementsInAssembly Ineligible elements in assembly.
Public property Static member MixedPhasesInAssembly Assembly cannot be created. All elements must have the same phases to be included in an assembly.
Public property Static member NoElementsAddedtoNewAssembly No elements were added to the assembly. No assembly will be created.
Public property Static member NoElementsLeftInExistingAssembly There are no elements left in the assembly. It will be disassembled.
Public property Static member NoEligibleElementsInAssembly No eligible elements in assembly.
Public property Static member SomeElementsPreventAssemblyTypeChange Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.
Top
See Also