External |
Returns an instance of an object that represents the external service with the given Id.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- serviceId ExternalServiceId
- Id of the service.
Return Value
ExternalServiceThe instance of the service or NULL if it cannot be found.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The returned instance is either of type SingleServerService or MultiServerService. Users should cast the returned object to one of the classes if they need access to active servers.