Multiply Operator


Transform Multiply Operator

Multiplies the two specified transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Transform operator *(
	Transform left,
	Transform right
)

Parameters

left Transform
The first transformation.
right Transform
The second transformation.

Return Value

Transform
The transformation equal to the composition of the two transformations.
Exceptions
Exception Condition
ArgumentNullException Thrown when the handle of the first or second transformation is .
Remarks
The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also