Custom |

Autodesk.Revit.DB CustomExporter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The CustomExporter type exposes the following members.

Name | Description | |
---|---|---|
![]() | CustomExporter | Constructs a new instance of a CustomExporter for a given document using the input instance of IExportContext as the output device. |

Name | Description | |
---|---|---|
![]() | Export2DForceDisplayStyle | This value tells the exporter of 2D views to force the given display mode for the view. |
![]() | Export2DGeometricObjectsIncludingPatternLines | This flag sets the exporter of 2D views to either include or exclude output of face pattern lines as part of geometric objects when the model is being processed by the export context. |
![]() | Export2DIncludingAnnotationObjects | This flag sets the exporter of 2D views to either include or exclude output of annotation objects when the model is being processed by the export context. |
![]() | IncludeGeometricObjects | This flag sets the exporter to either include or exclude output of geometric objects such as faces and curves when the model is being processed by the export context. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ShouldStopOnError | This flag instructs the exporting process to either stop or continue in case an error occurs during any of the exporting methods. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the CustomExporter |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | Export(IList ElementId ) | |
![]() | Export(View) | Exports one 3D or 2D view |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | IsRenderingSupported | Checks if view rendering is currently supported in the running instance of Revit. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The Export method of this class triggers standard rendering or exporting process in Revit, but instead of displaying the result on screen or printer, the output is channeled through the given custom context that handles processing of the geometric as well as non-geometric information.
Revit will process the exporting algorithm depending on the type of given context. If an instance of IPhotoRenderContext is used, then Revit will output the model as if executing the Render command, thus only such entities that would be visible in a rendered view will be sent to the context.
Alternatively, if an instance of IModelExportContext is used, Revit will output the model as if exporting it to a CAD format, a process which results outputting also objects that would not appear in a rendered image, such as model curves and text annotations.
For 2D views, an instance of IExportContext2D has to be used. Revit will output the contents of the 2D view as it is displayed on the screen. Export can be modified by setting properties pertaining to 2D views: Export2DGeometricObjectsIncludingPatternLines , Export2DIncludingAnnotationObjects . Export2DForceDisplayStyle . See notes for 2D export in IExportContext2D .