GetHandleSurface Method


Rebar Constrained Handle Get Handle Surface Method

Gets the surface of this handle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Surface GetHandleSurface()

Return Value

Surface
Returns the surface of this handle.
Exceptions
Exception Condition
InvalidOperationException RebarConstrainedHandle is no longer valid. -or- This handle doesn't belongs to a shape driven rebar.
Remarks
This function takes into account the handle behavior This function works only for shape driven rebar. Usualy the return surface is a plane. Only for segments of bars whose shape has a RebarShapeDefinitionByArc will return a cylindrical surface.
See Also