ComponentRepeaterIterator Class


Component Repeater Iterator Class

A slot iterator for ComponentRepeater.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ComponentRepeaterIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ComponentRepeaterIterator : IEnumerator<ComponentRepeaterSlot>

The ComponentRepeaterIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ComponentRepeaterIterator
Public method GetCurrent Returns the current repeater slot.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the iterator to the next item.
Public method Reset Resets the iterator to the initial state.
Top
See Also