Prompt |
This class contains options to control the behavior of interactive placement of family instances.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The PromptForFamilyInstancePlacementOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | PromptForFamilyInstancePlacementOptions | Creates a new PromptForFamilyInstancePlacementOptions using default options. |
![]() | PromptForFamilyInstancePlacementOptions(PromptForFamilyInstancePlacementOptions) | Creates a copy of an existing options object. |

Name | Description | |
---|---|---|
![]() | FaceBasedPlacementType | The placement type to be used if prompting to place an instance of a face-based family. This option is ignored if placing a non-face-based family. If placing a face-based family, Default is an acceptable value, but will correspond to the first available selection in the user interface. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | PlaceAirTerminalOnDuct | If true, when placing an air terminal, the terminal will be placed directly on the duct without fittings. If fase, the terminal will be placed with generated fittings. |
![]() | SketchGalleryOptions | The sketch option provided when promt to place a family instance. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the PromptForFamilyInstancePlacementOptions |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |