ComputeNormalizedParameter Method


Curve Compute Normalized Parameter Method

Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double ComputeNormalizedParameter(
	double rawParameter
)

Parameters

rawParameter Double
The raw parameter.

Return Value

Double
The real number equal to the normalized curve parameter.
Exceptions
Exception Condition
ArgumentException Thrown when rawParameter is infinite.
InvalidOperationException Thrown when the curve is unbound.
See Also