ISelectionFilter Interface


ISelection Filter Interface

An interface that provides the ability to filter objects during a selection operation.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface ISelectionFilter

The ISelectionFilter type exposes the following members.

Methods
Name Description
Public method AllowElement Override this pre-filter method to specify if the element should be permitted to be selected.
Public method AllowReference Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.
Top
See Also