SetUnderlineStatus Method (TextRange, Boolean)


Formatted Text Set Underline Status(Text Range, Boolean) Method

Sets the characters in a given text range to be underlined or not underlined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetUnderlineStatus(
	TextRange textRange,
	bool isUnderlined
)

Parameters

textRange TextRange
The given text range.
isUnderlined Boolean
The desired underline status of characters in the given text range. True to set underlined, false to set not underlined.
Exceptions
Exception Condition
ArgumentException This text range is empty. -or- This start index of this text range is not within the text range identifying the entire text. -or- The end of this text range is not within the text range identifying the entire text.
ArgumentNullException A non-optional argument was null
Remarks

Bullets, numbers, or letters of a list can not be underlined.

The given text range should not be empty.

See Also