MacroModule Class


Macro Module Class

A container for individual macros. As it relates to the macros editor, one MacroModule represents a project that can be loaded and edited from within the editor.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Macros MacroModule

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MacroModule : IEnumerable<Macro>, 
	IDisposable

The MacroModule type exposes the following members.

Properties
Name Description
Public property Environment The Macro environment.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MacroLanguageType The Macro language type.
Public property MacroManager The Macro manager.
Public property ModuleFolder The module folder.
Public property ModuleStatus The module status.
Public property Name The name of the module.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MacroModule
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetMacro Gets the macro with the give name.
Public method GetMacroModuleIterator Returns a Macro module iterator that iterates through the collection.
Top
See Also