GetDefaultPlacementPoint Method


Span Direction Symbol Get Default Placement Point Method

Gets the default placement point for the input element. The default position is in the middle of the bounding box of the top face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static XYZ GetDefaultPlacementPoint(
	Document document,
	LinkElementId elemIdToTag
)

Parameters

document Document
The document.
elemIdToTag LinkElementId
The ElementId of a Floor (either in the document or linked from another document).

Return Value

XYZ
Returns the default placement point for the input element. The default position is in the middle of the bounding box of the top face.
Exceptions
Exception Condition
ArgumentException The specified elemIdToTag should represent a Floor element.
ArgumentNullException A non-optional argument was null
See Also