ExternalFileUtils Class


External File Utils Class

A utility class containing functions related to external file references.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalFileUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternalFileUtils

The ExternalFileUtils type exposes the following members.

Methods
Name Description
Public method Static member GetAllExternalFileReferences Gets the ids of all elements which are external file references.
Public method Static member GetExternalFileReference Gets the external file referencing data for the given element.
Public method Static member GetFileBasedTempFolder Gets a temp folder based on the given file name
Public method Static member IsExternalFileReference Determines whether the given element represents an external file.
Top
Remarks
Elements which are external file references refer to files outside of the base .rvt file. Examples include Revit links, CAD links, the element which stores the location of the keynote file, and rendering decals.
See Also