TripleProduct Method


XYZ Triple Product Method

The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double TripleProduct(
	XYZ middle,
	XYZ right
)

Parameters

middle XYZ
The second vector.
right XYZ
The third vector.

Return Value

Double
The real number equal to the triple product.
Exceptions
Exception Condition
ArgumentNullException Thrown when middle or right is .
Remarks
The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.
See Also