Rating Property


Electrical System Rating Property

The Rating value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double Rating { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentException When setting this property: The given value for rating is not a number -or- When setting this property: The given value for rating is not finite
ArgumentOutOfRangeException When setting this property: The given value for rating must be non-negative.
InvalidOperationException This property only available when System Type is Power!
Remarks
This property is used to retrieve the Rating value of the Electrical System.
See Also