IsHvacSystemTypeId Method


Duct Is Hvac System Type Id Method

Checks if given type is valid HVAC system type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsHvacSystemTypeId(
	Document document,
	ElementId systemTypeId
)

Parameters

document Document
The document.
systemTypeId ElementId
ElementId of the HVAC system type to check.

Return Value

Boolean
True if the given systemTypeId is the HVAC system type, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also